Legacy Node SDK v2.2.14 released


Mark Lewis
 

v2.2.14 of the legacy Node SDK has been released, containing the following changes:
  • Dependency updates to address security vulnerability CVE-2022-25898.
  • Resolve an issue that could cause partial discovery results to be obtained under high load, and subsequent transaction failures.
  • Resolve an issue that could cause an unhandled promise rejection with exceptionally short commit timeouts.

If you are using (or can use) Fabric v2.4 then it is recommended to use the new Fabric Gateway client API instead.