Latest Minifab reports TARGET_ENV Error


Brett Tiller
 

I’ve just updated minifab, and when I run any commands then under # Verify TARGET_ENV is valid input ####   I now see the error: 

  The target environment must be set to either DOCKER, K8SCLASSIC, OR K8SOPERATOR. Currently is ''

 

For this issue, I’ve tried setting the Execution Context by exporting an environment variable TARGET_ENV, and even setting the Transient Data, but still see the same error.  And in the minifab help, there is no flag specified that may be used to set the target environment.

 

How do I set the target environment?

 

 

Thanks,

 

Brett Tiller

Sr. Software Engineer

984-349-4239 (mobile)

btiller@...

 

https://www.linkedin.com/company/securboration

 


email4tong@gmail.com
 

Thanks for reporting the issue. You can set it to DOCKER in the envsettings file. or you can do a cleanup command first, then you should get the latest.

On Wednesday, August 24, 2022, 10:27:19 AM EDT, Brett Tiller <btiller@...> wrote:


I’ve just updated minifab, and when I run any commands then under # Verify TARGET_ENV is valid input ####   I now see the error: 

  The target environment must be set to either DOCKER, K8SCLASSIC, OR K8SOPERATOR. Currently is ''

 

For this issue, I’ve tried setting the Execution Context by exporting an environment variable TARGET_ENV, and even setting the Transient Data, but still see the same error.  And in the minifab help, there is no flag specified that may be used to set the target environment.

 

How do I set the target environment?

 

 

Thanks,

 

Brett Tiller

Sr. Software Engineer

984-349-4239 (mobile)

btiller@...

 

https://www.linkedin.com/company/securboration

 


Brett Tiller
 

Thanks Tong.  I’ve set XX_TARGET_ENV=’DOCKER” in vars/envsettings and that resolved the error.

 

Brett Tiller

Sr. Software Engineer

984-349-4239 (mobile)

btiller@...

 

https://www.linkedin.com/company/securboration

 

From: email4tong@... <email4tong@...>
Sent: Wednesday, August 24, 2022 10:47 AM
To: fabric@...; Brett Tiller <btiller@...>
Subject: Re: [Hyperledger Fabric] Latest Minifab reports TARGET_ENV Error

 

Thanks for reporting the issue. You can set it to DOCKER in the envsettings file. or you can do a cleanup command first, then you should get the latest.

 

On Wednesday, August 24, 2022, 10:27:19 AM EDT, Brett Tiller <btiller@...> wrote:

 

 

I’ve just updated minifab, and when I run any commands then under # Verify TARGET_ENV is valid input ####   I now see the error: 

  The target environment must be set to either DOCKER, K8SCLASSIC, OR K8SOPERATOR. Currently is ''

 

For this issue, I’ve tried setting the Execution Context by exporting an environment variable TARGET_ENV, and even setting the Transient Data, but still see the same error.  And in the minifab help, there is no flag specified that may be used to set the target environment.

 

How do I set the target environment?

 

 

Thanks,

 

Brett Tiller

Sr. Software Engineer

984-349-4239 (mobile)

btiller@...

 

https://www.linkedin.com/company/securboration

 

Message Sender is EXTERNAL to Securboration. Carefully examine this message before you open any links or attachments.