gateway functionality in application


Nikos Karamolegkos <karamolegkos.n@...>
 

Hello, I can see here that there are two types of applications, gateway or not. The gateway related application as far as I know is for fabric 2.4.x version. However, can I use the other one (not the gateway one) with 2.4.x version?

-- 
Nikos Karamolegkos
Electrical Computer Engineer (TUC)
R & D engineer at ICS-FORTH
Telecommunications and Networks Lab (TNL)


David Enyeart
 

Yes, applications built using the legacy SDKs continue to work against Fabric v2.4 and beyond. We encourage new projects to utilize the new Gateway SDKs as the legacy SDKs will likely become deprecated this year given the upcoming Gateway SDK v1.1 and Fabric v2.5 LTS releases. The SDK maintainers are already starting to focus more on the Gateway SDKs in terms of improvements and maintenance, but the legacy SDKs will continue to work as it will take existing projects some time to shift over of the Gateway SDKs.

 

From: fabric@... <fabric@...> on behalf of Nikos Karamolegkos <karamolegkos.n@...>
Date: Friday, May 20, 2022 at 2:13 PM
To: fabric <fabric@...>
Subject: [EXTERNAL] [Hyperledger Fabric] gateway functionality in application

Hello, I can see here that there are two types of applications, gateway or not. The gateway related application as far as I know is for fabric 2.4.x version. However, can I use the other one (not the gateway one) with 2.4.x version? ‍ ‍ ‍ ‍ ‍ ‍ ‍

ZjQcmQRYFpfptBannerStart

This Message Is From an External Sender

This message came from outside your organization.

ZjQcmQRYFpfptBannerEnd

Hello, I can see here that there are two types of applications, gateway or not. The gateway related application as far as I know is for fabric 2.4.x version. However, can I use the other one (not the gateway one) with 2.4.x version?

-- 
Nikos Karamolegkos
Electrical Computer Engineer (TUC)
R & D engineer at ICS-FORTH
Telecommunications and Networks Lab (TNL)