Go chaincode compiler version 1.15? HLF v2.3 #fabric #fabric-chaincode #fabric-questions


@secure12
 

May I know if HLF supports Go version 1.15? In my chaincode, I uses ecdsa.VerifyASN1 which requires Go v1.15. When I attempt to install it on a peer, it returns with error
./chaincode.go:330:10: undefined: ecdsa.VerifyASN1
note: module requires Go 1.15
I am currently using the peer image hyperledger/fabric-peer:2.3.2. For the client, I tried using the peer binary v2.3.2 and the docker image hyperledger/fabric-tools:2.3.2. Both didn't work. The Go version of the latter is 1.15.
It is okay for me to use ecdsa.Verify which is supported in Go v1.14. But it is good to know what versions of Go do HLF support because I couldn't find it anywhere.