ORDERER_ADMIN env variables #fabric-orderer


Kumar Shantanu
 

Hello Team, 

I am trying to setup ORDERER_ADMIN_XX_XX values through environment variables however it doesn't seem to work,

For example, my docker-compose file says,

- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

however when the orderer node starts it says,

orderer1.build.| Admin.TLS.Enabled = false

orderer1.build.| Admin.TLS.PrivateKey = ""

orderer1.build.| Admin.TLS.Certificate = ""

orderer1.build.| Admin.TLS.RootCAs = []

orderer1.build.| Admin.TLS.ClientAuthRequired = false

orderer1.build.| Admin.TLS.ClientRootCAs = []

orderer1.build.| Admin.TLS.TLSHandshakeTimeShift = 0s


Can someone please suggest a solution here. I am using orderer version 2.3

Thanks
Shantanu


Chris Gabriel <alaskadd@...>
 

Hi Shantanu,

Can you please share all of your orderer env variables?  That may assist in helping.

Thanks

On Apr 27, 2021, at 5:29 PM, Kumar Shantanu <km.shantanu@...> wrote:

Hello Team, 

I am trying to setup ORDERER_ADMIN_XX_XX values through environment variables however it doesn't seem to work,

For example, my docker-compose file says,

- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

however when the orderer node starts it says,

orderer1.build.| Admin.TLS.Enabled = false

orderer1.build.| Admin.TLS.PrivateKey = ""

orderer1.build.| Admin.TLS.Certificate = ""

orderer1.build.| Admin.TLS.RootCAs = []

orderer1.build.| Admin.TLS.ClientAuthRequired = false

orderer1.build.| Admin.TLS.ClientRootCAs = []

orderer1.build.| Admin.TLS.TLSHandshakeTimeShift = 0s


Can someone please suggest a solution here. I am using orderer version 2.3

Thanks
Shantanu


Kumar Shantanu
 

Sure, here it is,

##############
image: hyperledger/fabric-orderer:2.3
environment:
- FABRIC_LOGGING_SPEC=INFO
- ORDERER_GENERAL_LISTENADDRESS=0.0.0.0
- ORDERER_GENERAL_LISTENPORT=7050
- ORDERER_GENERAL_LOCALMSPID=OrdererMSP
- ORDERER_GENERAL_LOCALMSPDIR=/tmp/orderer/orderers/orderer1.build.dlt/msp
# enabled TLS
- ORDERER_GENERAL_TLS_ENABLED=true
- ORDERER_GENERAL_TLS_PRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_GENERAL_TLS_CERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_GENERAL_TLS_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_KAFKA_TOPIC_REPLICATIONFACTOR=1
- ORDERER_KAFKA_VERBOSE=true
- ORDERER_GENERAL_CLUSTER_CLIENTCERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_GENERAL_CLUSTER_CLIENTPRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_GENERAL_CLUSTER_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_GENERAL_BOOTSTRAPMETHOD=none
- ORDERER_CHANNELPARTICIPATION_ENABLED=true
- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_TLS_CERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_ADMIN_TLS_PRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_ADMIN_TLS_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_ADMIN_TLS_CLIENTROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

####3

On Tue, Apr 27, 2021 at 11:46 PM Chris G <alaskadd@...> wrote:
Hi Shantanu,

Can you please share all of your orderer env variables?  That may assist in helping.

Thanks

On Apr 27, 2021, at 5:29 PM, Kumar Shantanu <km.shantanu@...> wrote:

Hello Team, 

I am trying to setup ORDERER_ADMIN_XX_XX values through environment variables however it doesn't seem to work,

For example, my docker-compose file says,

- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

however when the orderer node starts it says,

orderer1.build.| Admin.TLS.Enabled = false

orderer1.build.| Admin.TLS.PrivateKey = ""

orderer1.build.| Admin.TLS.Certificate = ""

orderer1.build.| Admin.TLS.RootCAs = []

orderer1.build.| Admin.TLS.ClientAuthRequired = false

orderer1.build.| Admin.TLS.ClientRootCAs = []

orderer1.build.| Admin.TLS.TLSHandshakeTimeShift = 0s


Can someone please suggest a solution here. I am using orderer version 2.3

Thanks
Shantanu


Chris Gabriel <alaskadd@...>
 

It seems it should work, but it is possibly using the generic orderer.yaml file and not your env variables.  So, you may want to double-check that you are working from the correct directory and you are calling the correct docker-compose config if you have multiples.


On Apr 28, 2021, at 1:32 AM, Kumar Shantanu <km.shantanu@...> wrote:

Sure, here it is,

##############
image: hyperledger/fabric-orderer:2.3
environment:
- FABRIC_LOGGING_SPEC=INFO
- ORDERER_GENERAL_LISTENADDRESS=0.0.0.0
- ORDERER_GENERAL_LISTENPORT=7050
- ORDERER_GENERAL_LOCALMSPID=OrdererMSP
- ORDERER_GENERAL_LOCALMSPDIR=/tmp/orderer/orderers/orderer1.build.dlt/msp
# enabled TLS
- ORDERER_GENERAL_TLS_ENABLED=true
- ORDERER_GENERAL_TLS_PRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_GENERAL_TLS_CERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_GENERAL_TLS_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_KAFKA_TOPIC_REPLICATIONFACTOR=1
- ORDERER_KAFKA_VERBOSE=true
- ORDERER_GENERAL_CLUSTER_CLIENTCERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_GENERAL_CLUSTER_CLIENTPRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_GENERAL_CLUSTER_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_GENERAL_BOOTSTRAPMETHOD=none
- ORDERER_CHANNELPARTICIPATION_ENABLED=true
- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_TLS_CERTIFICATE=/tmp/orderer/orderers/orderer1.build.dlt/tls/signcerts/cert.pem
- ORDERER_ADMIN_TLS_PRIVATEKEY=/tmp/orderer/orderers/orderer1.build.dlt/tls/keystore/94d3083485ebea73e4e2154776e3fd149edda3c4d5671dcc9c4981a492180b30_sk
- ORDERER_ADMIN_TLS_ROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_ADMIN_TLS_CLIENTROOTCAS=[/tmp/orderer/orderers/orderer1.build.dlt/tls/tlscacerts/tls-fabric-ca-build-dlt.pem]
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

####3

On Tue, Apr 27, 2021 at 11:46 PM Chris G <alaskadd@...> wrote:
Hi Shantanu,

Can you please share all of your orderer env variables?  That may assist in helping.

Thanks

On Apr 27, 2021, at 5:29 PM, Kumar Shantanu <km.shantanu@...> wrote:

Hello Team, 

I am trying to setup ORDERER_ADMIN_XX_XX values through environment variables however it doesn't seem to work,

For example, my docker-compose file says,

- ORDERER_ADMIN_TLS_ENABLED=true
- ORDERER_ADMIN_LISTENADDRESS=0.0.0.0:7053

however when the orderer node starts it says,

orderer1.build.| Admin.TLS.Enabled = false

orderer1.build.| Admin.TLS.PrivateKey = ""

orderer1.build.| Admin.TLS.Certificate = ""

orderer1.build.| Admin.TLS.RootCAs = []

orderer1.build.| Admin.TLS.ClientAuthRequired = false

orderer1.build.| Admin.TLS.ClientRootCAs = []

orderer1.build.| Admin.TLS.TLSHandshakeTimeShift = 0s


Can someone please suggest a solution here. I am using orderer version 2.3

Thanks
Shantanu