Peer instantiation error #fabric #fabric-sdk-node


indirajith
 

Sorry for multiple emails. But to give more information on the problem, I am sending the log of couchdb container. 

[notice] 2019-12-18T10:44:54.593120Z nonode@nohost <0.340.0> -------- chttpd_auth_cache changes listener died database_does_not_exist at mem3_shards:load_shards_from_db/6(line:395) <= mem3_shards:load_shards_from_disk/1(line:370) <= mem3_shards:load_shards_from_disk/2(line:399) <= mem3_shards:for_docid/3(line:86) <= fabric_doc_open:go/3(line:39) <= chttpd_auth_cache:ensure_auth_ddoc_exists/2(line:195) <= chttpd_auth_cache:listen_for_changes/1(line:142)
[error] 2019-12-18T10:44:54.593188Z nonode@nohost emulator -------- Error in process <0.341.0> with exit value:
{database_does_not_exist,[{mem3_shards,load_shards_from_db,"_users",[{file,"src/mem3_shards.erl"},{line,395}]},{mem3_shards,load_shards_from_disk,1,[{file,"src/mem3_shards.erl"},{line,370}]},{mem3_shards,load_shards_from_disk,2,[{file,"src/mem3_shards.erl"},{line,399}]},{mem3_shards,for_docid,3,[{file,"src/mem3_shards.erl"},{line,86}]},{fabric_doc_open,go,3,[{file,"src/fabric_doc_open.erl"},{line,39}]},{chttpd_auth_cache,ensure_auth_ddoc_exists,2,[{file,"src/chttpd_auth_cache.erl"},{line,195}]},{chttpd_auth_cache,listen_for_changes,1,[{file,"src/chttpd_auth_cache.erl"},{line,142}]}]}

May be this 'database_does_exist' would be the reason for error during instantiation?  Chaincode install operation succeeds though. 

Thank you,
Indirajith.

On Wed, 18 Dec 2019 at 13:28, indirajith via Lists.Hyperledger.Org <indirajithv=gmail.com@...> wrote:
Hi Baohua, 
Me to encoutering problems during chaincode instantiation. I don't use any SDKs. Just using CLI command but I get "Error: could not assemble transaction, err proposal response was not successful, error code 500, msg chaincode registration failed: container exited with 0" error. Could you please suggest me where should I look into to figure this out? The peer logs are in https://pastebin.com/gMPU8uyW. I am using 1.4.4 peer and orderers with Raft.

Thank you,
Indirajith.

On Thu, 12 Dec 2019 at 20:22, Baohua Yang <yangbaohua@...> wrote:
ankit,
Seems that's the policy issue, and have you joined the peer into the channel successfully? And what id are you using to do the installation?

Besides, I think this project might be helpful for you: https://github.com/yeasy/docker-compose-files/tree/master/hyperledger_fabric/

On Wed, Dec 11, 2019 at 12:31 AM <ankit.singh@...> wrote:
I am using fabric 1.4 with raft configuration. create channel, join channel, update anchor peers and install chaincode worked fine but facing this issue when trying to instantiate chaincode:

NodeJS logs:
(node:1463) UnhandledPromiseRejectionWarning: Error: Failed to instantiate the chaincode. cause:Error: instantiate proposal resulted in an error :: Error: failed to execute transaction 53450a9bb88694d82ab6c04f201f5016eecaf59140717d5ad2c4b4ba6710d48c: error sending: timeout expired while executing transaction

Blockchain logs:
Peer isn't eligible for channel mychannel : implicit policy evaluation failed - 0 sub-policies were satisfied, but this policy requires 1 of the 'Readers' sub-policies to be satisfied
peer0.org1.example.com    | runtime.goexit
peer0.org1.example.com    | /opt/go/src/runtime/asm_amd64.s:1337



--
Best wishes!

Baohua Yang


indirajith
 

Hi Baohua, 
Me to encoutering problems during chaincode instantiation. I don't use any SDKs. Just using CLI command but I get "Error: could not assemble transaction, err proposal response was not successful, error code 500, msg chaincode registration failed: container exited with 0" error. Could you please suggest me where should I look into to figure this out? The peer logs are in https://pastebin.com/gMPU8uyW. I am using 1.4.4 peer and orderers with Raft.

Thank you,
Indirajith.

On Thu, 12 Dec 2019 at 20:22, Baohua Yang <yangbaohua@...> wrote:
ankit,
Seems that's the policy issue, and have you joined the peer into the channel successfully? And what id are you using to do the installation?

Besides, I think this project might be helpful for you: https://github.com/yeasy/docker-compose-files/tree/master/hyperledger_fabric/

On Wed, Dec 11, 2019 at 12:31 AM <ankit.singh@...> wrote:
I am using fabric 1.4 with raft configuration. create channel, join channel, update anchor peers and install chaincode worked fine but facing this issue when trying to instantiate chaincode:

NodeJS logs:
(node:1463) UnhandledPromiseRejectionWarning: Error: Failed to instantiate the chaincode. cause:Error: instantiate proposal resulted in an error :: Error: failed to execute transaction 53450a9bb88694d82ab6c04f201f5016eecaf59140717d5ad2c4b4ba6710d48c: error sending: timeout expired while executing transaction

Blockchain logs:
Peer isn't eligible for channel mychannel : implicit policy evaluation failed - 0 sub-policies were satisfied, but this policy requires 1 of the 'Readers' sub-policies to be satisfied
peer0.org1.example.com    | runtime.goexit
peer0.org1.example.com    | /opt/go/src/runtime/asm_amd64.s:1337



--
Best wishes!

Baohua Yang


Baohua Yang
 

ankit,
Seems that's the policy issue, and have you joined the peer into the channel successfully? And what id are you using to do the installation?

Besides, I think this project might be helpful for you: https://github.com/yeasy/docker-compose-files/tree/master/hyperledger_fabric/

On Wed, Dec 11, 2019 at 12:31 AM <ankit.singh@...> wrote:
I am using fabric 1.4 with raft configuration. create channel, join channel, update anchor peers and install chaincode worked fine but facing this issue when trying to instantiate chaincode:

NodeJS logs:
(node:1463) UnhandledPromiseRejectionWarning: Error: Failed to instantiate the chaincode. cause:Error: instantiate proposal resulted in an error :: Error: failed to execute transaction 53450a9bb88694d82ab6c04f201f5016eecaf59140717d5ad2c4b4ba6710d48c: error sending: timeout expired while executing transaction

Blockchain logs:
Peer isn't eligible for channel mychannel : implicit policy evaluation failed - 0 sub-policies were satisfied, but this policy requires 1 of the 'Readers' sub-policies to be satisfied
peer0.org1.example.com    | runtime.goexit
peer0.org1.example.com    | /opt/go/src/runtime/asm_amd64.s:1337



--
Best wishes!

Baohua Yang


ankit.singh@...
 

I am using fabric 1.4 with raft configuration. create channel, join channel, update anchor peers and install chaincode worked fine but facing this issue when trying to instantiate chaincode:

NodeJS logs:
(node:1463) UnhandledPromiseRejectionWarning: Error: Failed to instantiate the chaincode. cause:Error: instantiate proposal resulted in an error :: Error: failed to execute transaction 53450a9bb88694d82ab6c04f201f5016eecaf59140717d5ad2c4b4ba6710d48c: error sending: timeout expired while executing transaction

Blockchain logs:
Peer isn't eligible for channel mychannel : implicit policy evaluation failed - 0 sub-policies were satisfied, but this policy requires 1 of the 'Readers' sub-policies to be satisfied
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip/channel.NewGossipChannel.func5
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/channel/channel.go:262
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip/channel.(*stateInfoCache).Add
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/channel/channel.go:998
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip/channel.(*gossipChannel).handleStateInfSnapshot
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/channel/channel.go:758
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip/channel.(*gossipChannel).HandleMessage
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/channel/channel.go:588
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip.(*gossipServiceImpl).handleMessage
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/gossip_impl.go:378
peer0.org1.example.com    | github.com/hyperledger/fabric/gossip/gossip.(*gossipServiceImpl).acceptMessages
peer0.org1.example.com    | /opt/gopath/src/github.com/hyperledger/fabric/gossip/gossip/gossip_impl.go:332
peer0.org1.example.com    | runtime.goexit
peer0.org1.example.com    | /opt/go/src/runtime/asm_amd64.s:1337