Python 3 support for #fabric-sdk-node


manojkumar.ragupathi@...
 

As per the Official Hyperledger Fabric Doc, "The Fabric Node.js SDK requires an iteration of Python 2.7 in order for npm install operations to complete successfully."
As per the https://pythonclock.org/ , "Python 2.7 will not be maintained past 2020. Originally, there was no official date. Recently, that date has been updated to January 1, 2020."

So, Hyperledger Fabric Node SDK, has to support Python 3 soon? Better to go with latest 
Python version, 3.8.0 for long run. 


Gari Singh <garis@...>
 

It was not really a Node SDK limitation but rather a node-gyp issue.  We require node-gyp as we use native modules.  The latest versions of npm ship with versions of node-gyp which support Python 3.5, 3.6 and 3.7.

Can you file a JIRA requesting doc update?
Or of course you can submit the change as well.

/ G

Gari Singh
garis@...
978-846-7499



On Nov 15, 2019, at 3:54 PM, manojkumar.ragupathi@... wrote:


As per the Official Hyperledger Fabric Doc, "The Fabric Node.js SDK requires an iteration of Python 2.7 in order for npm install operations to complete successfully."
As per the https://pythonclock.org/ , "Python 2.7 will not be maintained past 2020. Originally, there was no official date. Recently, that date has been updated to January 1, 2020."

So, Hyperledger Fabric Node SDK, has to support Python 3 soon? Better to go with latest 
Python version, 3.8.0 for long run.