Is Go supported in 1.4


Trevor Lee Oakley <trevor@...>
 

I heard the docs are out of date, can someone clarify if Go is supported in 1.4?
 


David Enyeart
 

Like everything in open source, 'support' is based on the goodwill of the community. The project maintainers do provide long-term support (LTS) guidance, to indicate which release streams will be the focus for bug fixes.
Go chaincode is part of Fabric v1.4.x which is currently the LTS release.
Go SDK is not yet on the same release cycle as Fabric and is therefore not included in the LTS guidance.


Dave Enyeart

"Trevor Lee Oakley" ---10/25/2019 08:13:06 AM---I heard the docs are out of date, can someone clarify if Go is supported in 1.4?

From: "Trevor Lee Oakley" <trevor@...>
To: <fabric@...>
Date: 10/25/2019 08:13 AM
Subject: [EXTERNAL] [Hyperledger Fabric] Is Go supported in 1.4
Sent by: fabric@...





I heard the docs are out of date, can someone clarify if Go is supported in 1.4?





Trevor Lee Oakley <trevor@...>
 

Thanks for this info. 
 
 
 

From: "David Enyeart" <enyeart@...>
Sent: 25 October 2019 08:53
To: trevor@...
Cc: fabric@...
Subject: Re: [Hyperledger Fabric] Is Go supported in 1.4
 

Like everything in open source, 'support' is based on the goodwill of the community. The project maintainers do provide long-term support (LTS) guidance, to indicate which release streams will be the focus for bug fixes.
Go chaincode is part of Fabric v1.4.x which is currently the LTS release.
Go SDK is not yet on the same release cycle as Fabric and is therefore not included in the LTS guidance.


Dave Enyeart

"Trevor Lee Oakley" ---10/25/2019 08:13:06 AM---I heard the docs are out of date, can someone clarify if Go is supported in 1.4?

From: "Trevor Lee Oakley" <trevor@...>
To: <fabric@...>
Date: 10/25/2019 08:13 AM
Subject: [EXTERNAL] [Hyperledger Fabric] Is Go supported in 1.4
Sent by: fabric@...





I heard the docs are out of date, can someone clarify if Go is supported in 1.4?