#fabric #fabric-chaincode #fabric #fabric-chaincode


soumya nayak <soumyarjnnayak@...>
 

Hi Team,
when i am upgrading the chaincode
its throwing me the error 

Endorse upgrade proposal, get response <status:500 message:"cannot get package for chaincode (ldbc:1.1)" >

using the below command i packaged --


peer chaincode package ldbcpackage.out -n ldbc -p ldbc -v 1.1 -s -S

post that i copied the ldbcpakcage.out file to the gopath but still i am getting the same error
how to go about this

peer chaincode upgrade -o $ORDERER_ADDRESS --tls --cafile $CORE_PEER_TLS_ROOTCERT_FILE -C legaldescriptionchannel -n ldbc -v 1.1 -c '{"Args":[]}' --clientauth --keyfile $CORE_PEER_TLS_CLIENTKEY_FILE --certfile $CORE_PEER_TLS_CLIENTCERT_FILE

do i have to place this .out file specifically somewhere


soumya nayak <soumyarjnnayak@...>
 

HI All,

Please ignore. Its resolved. I missed to install first the newer version of chaincode. 
Instead i was doing a direct upgrade.

Regards,
Soumya