Re: Fabric 2.0: commit readiness returns false but approvalformyorg returned success

Manindra Singh

Hi Nikhil,

In response to your following comment, I re-ran the commit readiness command with those options but still get the same result:
"I do not see the following parameters on the commit readiness command: --init-required true --signature-policy "AND ('Org1MSP.peer','Org2MSP.peer')" "
Command: peer lifecycle chaincode checkcommitreadiness -o --channelID allarewelcome --tls --cafile $ORDERER_TLS_CA -name sacc --version 1.0 --sequence 1 --init-required true --signature-policy "AND ('Org1MSP.peer','Org2MSP.peer')" --output json


"approvals": {
"Org1MSP": false,
"Org2MSP": false

Hi Chris,

In response to your following comment, please find the result of querying installed chaincodes, $
CC_PACKAGE_ID on Org1 peer(same result comes for Org2 peer also):
"If you query the peer for installed chaincodes, what is the output?
You are using a variable export ($CC_PACKAGE_ID) to represent the packageID. Please note actual value of $CC_PACKAGE_ID and make sure it matches the one in your output (in this instance from your log below...sacc_1.0:5562f868f6fd43ff8873f403aa52bc6928161fec933065d0b81e2193f6038bd0)"
Command: peer lifecycle chaincode queryinstalled
Installed chaincodes on peer:
Package ID: sacc_1.0:5562f868f6fd43ff8873f403aa52bc6928161fec933065d0b81e2193f6038bd0, Label: sacc_1.0

Command: echo $CC_PACKAGE_ID
Output: sacc_1.0:5562f868f6fd43ff8873f403aa52bc6928161fec933065d0b81e2193f6038bd0

Join to automatically receive all group messages.