Using Fabric Java SDK with v2.3.0 breaks code


vijayrv@...
 

Hi All,
Does the fabric java sdk break with 2.3.0? Here's what I observed. When you try  HFClient.newChannel()
Method used : public Channel newChannel(String name, Orderer orderer, ChannelConfiguration channelConfiguration byte[]... channelConfigurationSignatures
 you get an error : "channel001 expected config block type CONFIG_UPDATE, but got: MESSAGE". 
The same code executes normally when there was a system channel and a channel configtx was created using -outputCreateChannelTx.
Any thoughts?
Regards
Vijay

Join fabric@lists.hyperledger.org to automatically receive all group messages.