Re: Problems with Docker 2.4.0.0


Brett T Logan <brett.t.logan@...>
 

2.4.1 hasn't been released yet for Mac. The fix is in the 2.4.1 development branch, but not yet available.


Vipin Bharathan --- [EXTERNAL] Re: [Hyperledger Fabric] Problems with Docker 2.4.0.0 ---

From:"Vipin Bharathan" <vipinsun@...>
To:"Arnaud Le Hors" <lehors@...>
Cc:"Artem Barger" <bartem@...>, "Gari Singh" <garis@...>, "fabric" <fabric@...>
Date:Fri, Oct 9, 2020 12:24
Subject:[EXTERNAL] Re: [Hyperledger Fabric] Problems with Docker 2.4.0.0


Or go to Docker 2.4.1 as the poster suggests in https://lists.hyperledger.org/g/fabric/message/9108


On Fri, Oct 9, 2020 at 8:42 AM Arnaud Le Hors <lehors@...> wrote:
Ah, thanks! It surprised me that nobody had seen this one before me. Hopefully the title of my email will make it easier for others who run into this problem to find this thread. Searching for an answer didn't lead me anywhere...
--
Arnaud  Le Hors - Senior Technical Staff Member, Blockchain & Web Open Technologies - IBM




From:        "Artem Barger" <bartem@...>
To:        "Arnaud Le Hors" <lehors@...>
Cc:        fabric@...
Date:        10/09/2020 02:10 PM
Subject:        [EXTERNAL] Re: [Hyperledger Fabric] Problems with Docker 2.4.0.0
Sent by:        fabric@...




It seems that people already bumped into a similar issue, see here: https://lists.hyperledger.org/g/fabric/message/9108
And what needs to be done is you need to turn off the 'use gRPC FUSE' fuse option in your docker settings.
 
----- Original message -----
From: "Arnaud Le Hors" <lehors@...>
Sent by: fabric@...
To: fabric@...
Cc:
Subject: [EXTERNAL] [Hyperledger Fabric] Problems with Docker 2.4.0.0
Date: Fri, Oct 9, 2020 2:47 PM

I upgraded my Docker install on my Mac to the latest version that just came out to find out that Fabric stopped working. It appears to break the way we use Docker in Docker to install chaincode:


$ peer lifecycle chaincode install fabcar.tar.gz
Error: chaincode install failed with status: 500 - failed to invoke backing implementation of `InstallChaincode': could not build chaincode: docker build failed: docker image inspection failed: Get "
http://unix.sock/images/dev-peer0.org1.example.com-fabcar_1-65710fa851d5c73690faa4709ef40b798c085e7210c46d44f8b1e2d5a062c9b0-0ca9287fd994c9e3127d7fbba2f50ee23bae41fca7349e5a02c07da5bccc19d2/json": dial unix /host/var/run/docker.sock: connect: no such file or directory

I'm no expert here so somebody with better understanding will need to dig this one up but what I noticed is that /host/var/run/docker.sock somehow appears as a symlink within the peer (it is on the host but I don't think that should be surfaced within the container):


$ docker exec -it peer0.org1.example.com ls -l /host/var/run/docker.sock
lrwxr-xr-x 1 root root 67 Oct 9 10:53 /host/var/run/docker.sock -> /Users/lehors/Library/Containers/com.docker.docker/Data/docker.sock

Instead, it looks like this with Docker 2.3.0.5:

 



$ docker exec -it peer0.org1.example.com ls -l /host/var/run/docker.sock
srw-rw----    1 root     root             0 Oct  9 11:27 /host/var/run/docker.sock


If you need to downgrade back to the previous version of Docker the link to the older version is available from the Docker release notes page:

https://docs.docker.com/docker-for-mac/release-notes/
--
Arnaud  Le Hors - Senior Technical Staff Member, Blockchain & Web Open Technologies - IBM

 

 





Join fabric@lists.hyperledger.org to automatically receive all group messages.