Re: Build fabric on raspberry pi #fabric


Brian Behlendorf <bbehlendorf@...>
 

Looks like if gcc can't find ld, there's a common developer package or two you're missing. My guess is you're on Ubuntu or something Debian-ish, do you have the binutils package installed?

Brian

On 9/4/20 6:03 AM, kokolaki@... wrote:
I am trying to install fabric version 2.2.0 in raspperry pi. I cloned fabric repository and checkout to appropriate tag. I use last version of golang go1.15.1 linux/arm64
 when I run "make" to generate, I have the following error:
# github.com/hyperledger/fabric/cmd/peer
/usr/local/go/pkg/tool/linux_arm64/link: running gcc failed: exit status 1
collect2: fatal error: cannot find 'ld'
compilation terminated.

make: *** [Makefile:209: build/bin/peer] Error 2
Removing intermediate container d41a9d6e8573
The command '/bin/sh -c make peer GO_TAGS=${GO_TAGS}' returned a non-zero code: 2
Makefile:224: recipe for target 'build/images/peer/.dummy-arm64-2.2.0-snapshot-5ea85bc54' failed
make: *** [build/images/peer/.dummy-arm64-2.2.0-snapshot-5ea85bc54] Error 2

Any help?
Thnak you.


-- 
Brian Behlendorf
Executive Director, Hyperledger
bbehlendorf@...
Twitter: @brianbehlendorf

Join fabric@lists.hyperledger.org to automatically receive all group messages.