Fabric 2.1.1 on EKS - can't install chaincode #fabric #fabric-kubernetes #fabric-chaincode


julian@...
 

Hello. I have setup a 2.1.1 fabric on AWS EKS, version: v1.15.11-eks-af3caf. 
 
I have created a channel, and joined multiple peers. Next I tried to deploy a chaincode package using peer lifecycle chaincode install, but it fails with the following message: 

2020-07-27 10:14:26.622 UTC [dockercontroller] buildImage -> ERRO f85 Error building image: docker build failed: Error returned from build: 1 "+ INPUT_DIR=/chaincode/input
+ OUTPUT_DIR=/chaincode/output
+ cp -R /chaincode/input/src/. /chaincode/output
+ cd /chaincode/output
+ '[' -f package-lock.json -o -f npm-shrinkwrap.json ]
+ npm ci '--only=production'
npm ERR! code EAI_AGAIN
npm ERR! errno EAI_AGAIN
npm ERR! request to https://registry.npmjs.org/fabric-shim/-/fabric-shim-2.0.0.tgz failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org
 
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-07-27T10_14_22_477Z-debug.log
"
2020-07-27 10:14:26.622 UTC [dockercontroller] buildImage -> ERRO f86 Build Output:
 
This looks like a name resolution error. Pods on the EKS cluster have connectivity to the internet. From the peer I'm able to download https://registry.npmjs.org/fabric-shim/-/fabric-shim-2.0.0.tgz without issue.

I have tried playing with the following peer properties, but with no success.

Does anyone have any recommendations for troubleshooting this issue?

CORE_VM_DOCKER_HOSTCONFIG_NETWORKMODE

CORE_VM_DOCKER_HOSTCONFIG_DNS


Join fabric@lists.hyperledger.org to automatically receive all group messages.