Re: chaincode instantiation successful but chaincode not found

Matthew White
 

Hello;
 
I can't say for certain, but it looks like the metadata that is being generated (see line 17 of the cc-output.txt) doesn't seem quite correct.
Can you double check the structure of the contract, specifically around the requirements for `index.js`.
 
 
 
Or if you can share a link to the whole contract?
 
 
Regards, Matthew.
Matthew B White  IBM Blockchain Solutions Architect
 
Email me at WHITEMAT@...
Find me on StackOverflow, and generally at  calanais.me.uk
 
Note: restricted availability for meetings 14:30 to 17:00 UK Tuesday 
IBM United Kingdom Limited, Hursley Park, Winchester, Hampshire, SO21 2JN

"The wrong answers are the ones you go looking for when the right answers stare you in the face"
 
 
 
----- Original message -----
From: "Abhijeet Bhowmik" <abhijeet@...>
Sent by: fabric@...
To: fabric@...
Cc:
Subject: [EXTERNAL] [Hyperledger Fabric] chaincode instantiation successful but chaincode not found
Date: Mon, Jul 13, 2020 5:44 AM
 
Dear All,
 
I was able to successfully install and instantiate chaincode but when I try to invoke it, it says that chaincode is not found. I ran chaincode list command but the output is empty, I retried instantiating cc again several times but still the same result. PFA peer and cc container logs
 
Thanks a lot
Abhijeet Bhowmik
 
Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number 741598.
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU

Join fabric@lists.hyperledger.org to automatically receive all group messages.