Re: Error: failed to create deliver client


Marina Wanis <marinamaged1996@...>
 

Hi Faisal,

 

I copied the environment variable incomplete by mistake.

TLS_PARAMETERS=" --tls true --cafile $ORDERER_CA_ROOTFILE"

 

export ORDERER_CA_ROOTFILE=$PWD/crypto-config/ordererOrganizations/phone.com/orderers/orderer.phone.com/msp/tlscacerts/tlsca.phone.com-cert.pem

 

I’m still getting this error:

 

2020-02-14 19:10:28.886 +04 [main] InitCmd -> WARN 001 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable

2020-02-14 19:10:28.888 +04 [main] SetOrdererEnv -> WARN 002 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable

Error: failed to create deliver client: orderer client failed to connect to orderer.phone.com:7050: failed to create new connection: context deadline exceeded

 

 

Sent from Mail for Windows 10

 

From: Faisal
Sent: Friday, February 14, 2020 10:52 AM
To: fabric@...
Subject: Re: [Hyperledger Fabric] Error: failed to create deliver client

 

all the path to the file after the --cafile parameter your command should be include the tlsca.pem file 

export TLS_PARAMETERS = --tls true --cafile /PATH/tlsca.phone.com-cert.pem

 

 

Join fabric@lists.hyperledger.org to automatically receive all group messages.