Re: Consenter error after docker images update

Jay Guo

it seems that requests are submitted too quickly, before `allarewelcome` channel completes its start phase. Could you try inject a sleep before failed operation and try again?

- J

On Sun, Jan 19, 2020 at 1:22 AM Niklas Krohn <niklas.krohn1@...> wrote:
Hi all, 

So to describe the situation: This is just the basic starterFiles-network based on BYFN. I set up a simple script deploying the network, and it all worked fine 7 days ago. However, in the meantime I updated all docker images on the computer and now when I run the bootstrap script, it fails halfway in it. 

I read about the issue here -, but it seems like kafka-nodes and zookeeper-nodes are fine? Issue seems to be between orderer and peers?

I suspect there might be two possible explanations:
- I updated the docker images today, then there is something that needs to be some adjustments to orderer config? I believe this maybe due to the fact that everything worked fine 7 days ago before I updated all images. 
- There are some mixups between the ports that the docker containers use? 

The error messages are easy to locate in orderer and peer logs below, in addition to last line in bootstrap-script. However, I do struggle to find the way to a solution. I obviously already tried to teardown the network, restart computer and recreated new crypto material and re-start the network, with same error message. 

Appreciate all hints in the right direction. Thank you! 



Bootstrap script with error message - the script stops at last line, when it tries to install chaincode on peer1, after successfully doing it on peer0:


Orderer log:


Peer0.org1 log:


Peer1.org1 logs:


Kafka node log:


Zookeeper node log:


Ports overview:


orderer info from docker-compose.yml:


peer0 info from docker-compose.yml:


peer1 info from docker-compose.yml:


Join to automatically receive all group messages.