Re: Fabric Explorer - Unable to connect to the fabric

Nick Frunza
 

Explorer as of now is one instance per network, you'll have to run 

blockchain-explorer/app/persistence/fabric/postgreSQL/db/createDB.sh to clean DB, and start from scratch.

If you use the same PC for fabric network, you may need to clean your docker's, run 

$docker stop $(docker ps -a -q) && docker rm -f $(docker ps -a -q)  && rm -rf ./crypto-config/* && rm -rf ~/.hfc*




On Sun, Apr 14, 2019 at 10:59 PM Karthikeyan Annamalai <writetokarthikeyan@...> wrote:
Hi Nick,
Thanks for the response.I had to run sync script to bring the data. Also, what if I need to connect to a new network ?


From: Nick Frunza <nfrunza@...>
Sent: Monday, April 15, 2019 3:54:55 AM
To: Karthikeyan Annamalai
Cc: fabric@...
Subject: Re: [Hyperledger Fabric] Fabric Explorer - Unable to connect to the fabric
 
If you navigate to logs/console you will see console.log files, also under logs/app/app.log, email the first 20 lines,
please make sure basic network is up, if you switch from one fabric network to another you may have some problems.



On Sat, Apr 13, 2019 at 11:42 AM Karthikeyan Annamalai <writetokarthikeyan@...> wrote:
Guys,

I am unable to connect to the locally running basic network. Here is my hl-explorer config:


{
  "network-configs": {
    "network-1": {
      "version": "1.0",
      "clients": {
        "client-1": {
          "tlsEnable": false,
          "organization": "Org1MSP",
          "channel": "mychannel",
          "credentialStore": {
            "path": "./tmp/credentialStore_Org1/credential",
            "cryptoStore": {
              "path": "./tmp/credentialStore_Org1/crypto"
            }
          }
        }
      },
      "channels": {
        "mychannel": {
          "peers": {
            "peer0.org1.example.com": {}
          },
          "connection": {
            "timeout": {
              "peer": {
                "endorser": "6000",
                "eventHub": "6000",
                "eventReg": "6000"
              }
            }
          }
        }
      },
      "organizations": {
        "Org1MSP": {
          "mspid": "Org1MSP",
          "fullpath": false,
          "adminPrivateKey": {
            "path": "/home/ubuntu/fabric-samples/basic-network/crypto-config/peerOrganizations/org1.example.com/users/Admin@.../msp/keystore"
          },
          "signedCert": {
            "path": "/home/ubuntu/fabric-samples/basic-network/crypto-config/peerOrganizations/org1.example.com/users/Admin@.../msp/signcerts"
          }
        },
        "OrdererMSP": {
          "mspid": "OrdererMSP",
          "adminPrivateKey": {
            "path": "/home/ubuntu/fabric-samples/basic-network/crypto-config/ordererOrganizations/example.com/users/Admin@.../msp/keystore"
          }
        }
      },
      "peers": {
        "peer0.org1.example.com": {
          "tlsCACerts": {
            "path": "/home/ubuntu/fabric-samples/basic-network/crypto-config/peerOrganizations/org1.example.com/peers/peer0.org1.example.com/tls/ca.crt"
          },
          "url": "grpc://127.0.0.1:7051",
          "eventUrl": "grpc://127.0.0.1:7053",
          "grpcOptions": {
            "ssl-target-name-override": "peer0.org1.example.com"
          }
        }
      },
      "orderers": {
        "orderer.example.com": {
          "url": "grpc://127.0.0.1:7050"
        }
      }
    },
    "network-2": {}
  },
  "configtxgenToolPath": "/home/ubuntu/fabric-samples/bin",
  "license": "Apache-2.0"
}

The explorer has no console error, the build was successful and when I load the explorer no data found. I guess this is an issue with the config for sure. Any help is appreciated.

Is there any other alternative for the hl-explorer?


Regards,
Karthikeyan Annamalai





--
Nik Frunza



--
Nik Frunza

Join fabric@lists.hyperledger.org to automatically receive all group messages.