Re: Error while Install the Fabric CA

Raj Shekhar Bhardwaj
 

Hi,

Please use below repo for better understanding as video reference is also present for it.
Youtube video link for reference- https://www.youtube.com/watch?v=ubrA3W1JMk0&t=1280s

Please let me know if you find any issues.

On Thu, Mar 28, 2019 at 2:57 PM <smitalchaudhari21@...> wrote:
Hello All,

I am new to hyperldger fabrics framework,
My details components are 
Kubernetes v1.11.0+d4cacc0 and OKD v3.11.0+d0c29df-98 (openshift web console)
helm versionClient: {SemVer:"v2.13.0"}Server: {SemVer:"v2.13.0"} with oc v1.5.1+7b451fc on windows 10,
Kubectl tool for fabrics configuration Client Version: {Major:"1", Minor:"11+", GoVersion:"go1.10.3", Compiler:"gc", Platform:"windows/amd64"}
Server Version: {Major:"1", Minor:"11+",GoVersion:"go1.10.3", Compiler:"gc", Platform:"linux/amd64"}
Currently I am using https://github.com/aidtechnology/lf-k8s-hlf-webinar steps for the hyperldger fabrics configuration.
When I Installed the Fabric CA chart (it automatically creates a postgresql database) with command "helm install stable/hlf-ca -n ca --namespace blockchain -f ./helm_values/ca_values.yaml"
 It display error as 
 1)ca-postgresql
 create Pod ca-postgresql-0 in StatefulSet ca-postgresql failed error: pods "ca-postgresql-0" is forbidden:
 unable to validate against any security context constraint: [fsGroup: Invalid value: []int64{1001}: 1001 is not an allowed group spec.initContainers[0].securityContext.securityContext.runAsUser:
 Invalid value: 0: must be in the ranges: [1001380000, 1001389999] spec.containers[0].securityContext.securityContext.runAsUser: Invalid value: 1001: must be in the ranges: [1001380000, 1001389999]]
 
 2)pod ca-hlf-ca
 0/1 nodes are available: 1 node(s) didn't match pod affinity rules, 1 node(s) didn't match pod affinity/anti-affinity.
 
Pods are in pending status.

Regards,
Smita

Join fabric@lists.hyperledger.org to automatically receive all group messages.