Re: unable to fetch config block of system channel from the orderer pod #orderer #fabric-orderer #fabric-kubernetes #fabric-questions #grpc


Vijaya Bhaskar
 

The system is working now. documenting just in case if any1 in future facing the same errors which I faced.

1)while doing a system channel update if you face the below error, check your admin cert in the map (which should be the admin sign cert from the org admin directory)

Error: got unexpected status: BAD_REQUEST -- error applying config update to existing channel 'syschannel': initializing channelconfig failed: could not create channel Consortiums sub-group config: setting up the MSP manager failed: admin 0 is invalid [The identity does not contain OU [CLIENT], MSP: [usisp],The identity does not contain OU [ADMIN], MSP: [usisp]]

2)on adding a consortium, if the error is indicating that the channel does not have capabilities (while deploying chaincode), check the configtx.yaml of the new org in the new consortium. It should include the below part and linked in the consortium definition

Capabilities:
Global: &ChannelCapabilities
V2_0: true
Orderer: &OrdererCapabilities
V2_0: true
Application: &ApplicationCapabilities
V2_0: true

Join fabric@lists.hyperledger.org to automatically receive all group messages.