Chaincode container not starting up for one org


mrudavshukla@...
 
Edited

Seems the chaincode container took time to instantiate. I waited for about 30 minutes and it started up. But still, this was unusual. Correct me if I'm wrong.
--------------------------
Hi,

I've deployed a multi-org(4) fabric network to four different aws instances. These are connected via docker swarm.

Next, I followed this tutorial for deploying chaincode to multi-org fabric network. I was able to successfully start up the network and consume APIs from composer-rest-server.

Further, I had some updates in my BNA. So I recreated the archive. Deleted all the old cards and repeated the steps of this tutorial for deploying updated archive. (I know I could've just upgraded the network but that throws a different error and is a different issue.)

Again, I was able to successfully install the updated archive in all the orgs and recreate new cards.

Now, when I try to start the network using composer-network-start, the chaincode container for three orgs starts up. However, for one of the org it doesn't start.

What problem it creates:

  • My endorsement policy requires all the orgs to endorse a transaction. However, since one of the chaincode containers is not up, I keep getting ENDORSEMENT_POLICY_FAILURE error on trying to ping or starting the rest server.

What I tried:

  • Checked logs of orderer and all the peers. None of them reports any kind of error.
  • At first, the disk space of the instance might be creating some issues as it was low already. I increased that. Didn't work.
  • Next, I reboot all the instances. Deleted the old docker containers and pruned the docker volume. Recreated the fabric network and installed the updated bna. Didn't work.
  • Deleted the old docker containers and pruned the docker volume. Recreated the fabric network and installed the OLD bna. IT WORKED. Chaincode containers of all the orgs started. However, this is old bna which I don't want to use.
  • I tried searching StackOverflow and GitHub for this one but with no luck.

What versions am I using:

  • Hyperledger Fabric: 1.1
  • Hyperledger Composer: 0.19.8

What questions I have:

  • What could be causing this issue?
  • Am I missing out some step? Or maybe not cuz I'm able to start previous bna on all the orgs.
Best,
Mrudav

Join composer@lists.hyperledger.org to automatically receive all group messages.