Re: Caliper leveldb query error


George
 

Thanks for your reply.

Is there any way to fix this for levelDB, because all my testing are based on this, like changing the function by myself  or its complicated and time consuming?

 

Thanks

 

Sent from Mail for Windows 10

 

From: Attila Klenik
Sent: Τετάρτη, 4 Δεκεμβρίου 2019 12:55
To: nigogokr@...; caliper@...
Subject: Re: [Hyperledger Caliper] Caliper leveldb query error

 

Hi George,

 

If the chaincode uses the "getQueryResult" chaincode stub method to perform a rich query, then the underlying world state DB must support this. Currently, this means you have to use CouchDB, independently of the Fabric version you use.

 

Regards,

Attila Klenik

Ph.D. Student @ Fault Tolerant Systems Research Group,

Department of Measurement and Information Systems,

Faculty of Electrical Engineering and Informatics,

Budapest University of Technology and Economics

 

E-mail: klenik@...

 

-----Eredeti üzenet-----

Feladó: caliper@... <caliper@...> E személy nevében: George via Lists.Hyperledger.Org

Küldve: Monday, December 2, 2019 4:19 PM

Címzett: caliper@...

Másolatot kap: caliper@...

Tárgy: [Hyperledger Caliper] Caliper leveldb query error

 

Hello

My name is George and Im a student from Greece. During the benchmark on caliper i get these errors:

- Proposal response error by peer0.org1.example.com: GET_QUERY_RESULT

failed: transaction ID:

c3f8001687ffb79f411a29510a573ff77da6237645d808ed2e395490880ba1ee:

ExecuteQuery not supported for leveldb

 

Is there any way to fix this for leveldb or do I have to switch to couchdb?The version that im running is v1.4

 

Thanks in advance

 

 

 

 

 

 

 

Join {caliper@lists.hyperledger.org to automatically receive all group messages.